CrystalDesigner tutorial

This tutorial will give you an introduction to CrystalDesigner. As an example through the tutorial, the cubic perovskite CaTiO3 will be used (high temperature phase). You will be guided through four sections. The first section describes how to enter the crystal structure data, while the last three sections describe how to create different graph views of the crystal structure entered.

The first graph view section you will learn how to create a unit cell from the crystal structure data entered. You will also learn how to insert bonds and how to define polyhedra around atoms. In addition a description on how to measure distances and angles between atoms is also present.

In the second graph view section you will learn to create a graphical representation of a plane through the crystal structure. It will also be shown how to add thickness to the plane and how to shift distance from origin. At the end of this tutorial you will learn how to make a graph view of the coordination around an atom.

 

Entering the Crystal Structure Data

Document window

When you start CrystalDesigner a new untitled window appears on screen, shown in figure 3.1.

Figure 3.1 A new untitled document window. No data has yet been entered.

This window is called the document window. The document window contains the data of the crystal structure. The window consists of four regions; the crystal system, the space group, the lattice parameters, and the atom positions region. From the data entered in these regions you can create as many graph windows as you like representing different views of the crystal structure. Let us start by entering the crystal structure data of CaTiO3 into the document window.

Crystal system

The first thing you need to do is to select the crystal system from the popup menu in the document window. Choose the Cubic crystal system as shown in figure 3.2.

Lattice parameters

After choosing the cubic crystal system, enter CaTiO3 crystal structure lattice parameter into the edit box in the lattice parameter region, a = b = c = 380 pm. Enter the lattice parameter. Only numbers and the decimal separator character are accepted. Please note that CrystalDesigner uses the decimal separator character defined by your system software. End the input with pressing the tab key.

Space group

Cubic perovskite has space group symmetry Pm-3m (221). Choose this entry from the Space Group popup menu.

Atom positions

Cubic perovskite (CaTiO3) contains three atom positions. Only one atom position is currently defined. Add therefore two new atom positions by choosing Add Atom Position two times from the Edit menu, as shown in figure 3.2.


Figure 3.2 This figure shows a popup menu for choosing a crystal system. The second menu is the Edit menu. Here, the user is adding an atom position to the atom position table.

 

Select the first cell in the element column in the atom position table. The first atom position to enter is calcium. You can either type in the symbol, the element number or choose the element from the arrow popup menu located on the right side of the input field. Figure 3.3 shows the document window at this stage when the popup menu are pulled down.

Figure 3.3. The document window with the element popup menu pulled down.

 

Calcium is located in the origin of the unit cell, (0 0 0). Enter the coordinates. You can navigate between the different cells by using the tab or arrows keys or you can just click in the cell that you want to change or enter a new value.

To complete the entering of the atom position of calcium, you also need to enter the radius of the element. You can enter the radius directly or you can let CrystalDesigner suggest a radius by opening the lookup table by clicking Look Up button on the left side of the input field. Figure 3.4 shows the Radius Lookup Table Dialog.

Figure 3.4. Radius lookup table dialog window.

CaTiO3 is an ionic crystal structure and the calcium atoms have oxidation state two and they are twelve coordinated. You can select the correct radius by clicking on the specific row. To return to the document window, click OK. Press tab key to confirm the radius you just selected.

Complete the rest of the atom positions by inserting the values given in figure 3.5. Remember to confirm the last cell you enter.

Figure 3.5 The document window when all crystal structure data are entered. Please note that CrystalDesigner uses the decimal separator character defined by your system software.

Save data

It is time for saving the data. Choose Save Crystal Structure from the File menu (not possible in the demo version). You may name the file Perovskite. The dialog should then look like figure 3.6 when you save the data. Click Save.

Figure 3.6 An example of a standard file dialog box.

 

Creating a unit cell drawing

A unit cell drawing can be created by choosing New Unit Cell View from the Windows menu as shown in figure 3.7. The unit cell window, also shown in figure 3.7, will then be created.

 

Figure 3.7 The Windows menu and a graph window displaying a unit cell.

In addition, two floating windows are also shown when the unit cell window is in front. These windows are shown in figure 3.8 and they are only visible when a graph window is in front. By activating the document window containing the crystal structure data the floating windows will disappear again. To bring the unit cell window in front again choose Perovskite, Unit Cell from the Windows menu.

Figure 3.8. TFloating windows. The empty window is the Info Window. The window containing the icons is the Tool Window.

Distances and angles between atoms

 
The arrow icon shown in the margin is called the Selection Tool. With this tool selected you can select different atoms in the drawing.

When an atom is selected the information about the atom is shown in the info window. By shift clicking you can select up to four different atoms. The info window will then display information about the distance, angle or torsion angle between the selected atoms. You can deselect the atoms by clicking somewhere else in the drawing.

Rotation of the drawing

 
The globe icon is called the Free Rotation Tool. With this tool selected you can rotate the unit cell in space by mouse dragging. Press the option key to toggle between real time and silhouette type rotation.

Try to rotate your unit cell. A circle in the drawing is shown when a rotation task is performed. The circle symbolise a silhouette of a sphere. It will help you to make the rotation easier. It is also possible to rotate the drawing by using the arrow keys.

 

Inserting bonds

To define bonds, choose Insert/ Modify Bonds from the Bonds menu. Insert bonds between the calcium atoms . After you have selected the atoms involved in the bonds, click the Add button. Your dialog at this stage should look like the dialog in figure 3.9.

Figure 3.9. The edit bonds dialog.

Click OK. The drawing now displays the coordination bonds between oxygen atoms and titanium atoms. Figure 3.10 shows the graph window when the bonds have been inserted. Your graph window may have been rotated differently.

Figure 3..10 A graph window displaying a unit cell of CaTiO3 with coordination bonds defined between oxygen and titanium atoms.

Inserting polyhedra

To insert a polyhedron around the titanium atom, choose Insert Polyhedra Around and the sub entry Titanium from the Polyhedra menu as shown in figure 3.11. Please note that elements involved in a bond can not be drawn polyhedra around.

Figure 3.11. The Polyhedra menu. The user is inserting polyhedra around titanium atoms.
 

CrystalDesigner automatically calculates the coordination polyhedra around titanium, which in this case is an octahedron. Figure 3.12 contains a graph window where eight unit cells are displayed. Choose (2x2x2) Units from the Size menu to view these eight unit cells.

Figure 3.12. A graph window displaying a unit cell of CaTiO3 with coordination polyhedra defined between around the titanium atoms.
 

Choose Save Crystal Structure from the File menu to save your current work. If you want to save your unit cell graph to a PICT file, you can choose Save Graphics from the File menu to save the drawing to a file.

 

Viewing a plane in the crystal structure

In this section you will learn how to create a graphical representation of a plane through the crystal structure. It will also be shown how to add thickness to the plane and how to shift distance from origin.

Defining a plane

To create a new plane view, choose New Plane View from the Windows menu as shown in figure 3.13.

Figure 3.13. The window menu. The user is creating a new plane view.

A dialog box appears on the screen. In this dialog box you can select the hkl plane you want to view. In this tutorial, select the (111) plane. This can be done by entering the numbers or by choosing the plane from popup menu named Predefined. At this stage your dialog should look like figure 3.14.

Figure 3.14. The plane info dialog box. The user has selected the (111) plane.

Moving the plane away from origin

The boundary of the plane displayed is defined by the first octant. In the case where one of the crystallographic axes is parallel to the plane, you can define how many unit cells that should be included in the specific direction. In our case none of the axes are parallel to the displayed plane.

The current plane is at a distance d from origin. To incorporate more atoms in the drawing you can transfer the defined plane away from origin by an integer multiply of d. This is possible by choosing a sub entry of the menu item Distance from Origin from the Size menu. Choose 7d as shown in figure 3.15.

Figure 3.15 The Size and Atoms menus. In the Size menu the user transfers a plane to a distance 7d from origin. In the Atoms menu the user selects an entry to change the relative atom radius.

 

To see the close-packing of this layer, change the relative size of the atoms to 100%. Choose Relative Size from the Atoms menu. Enter the value 100 and click OK. Your graph window should now look like figure 3.16.

Figure 3.16. A graphical representation of the (111)plane at a distance of 7d from origin. The relative size of the atoms is set to 100%.
 

Adding thickness to a plane

Often it is interesting to see the packing of the layers of a crystal structure. This can be done by adding a thickness to a plane. To add thickness to the plane, choose Other Plane Size from the Size menu. A dialog as shown in figure 3.17 appears. Change the thickness above the plane to 1000 pm and click OK.

Figure 3.17. A plane size dialog box. A thickness of 1000 pm above the plane has been entered.

After a rotation the plane the drawing of the plane may look something like figure 3.18.

Figure 3.18. A graphical representation of the (111)plane in a distance 7d from origin. The relative size of the atoms is set to 100% and the thickness above the plane is set to 1000 pm.
 
 

Viewing a coordination around a atom

To view the coordination around a atom, choose New Coordination View from the Windows menu. Select the calcium atom as shown in figure 3.19 and click OK.


Figure 3.19. A dialog where the user can select an atom to view coordination around. Calcium (0,0,0) has been selected.
 

A new window viewing the coordination of calcium then appears. Atoms within a given radius are included in this drawing. The given radius (R) is calculated by the equation

R = r0 + a

where r0 is the distance to the nearest neighbour and a is the acceptable variation in distance from the core atom between the neighbouring atoms. The default value of is 20 pm.

You can change the values of R and a. To change R directly, choose Other Radius ... from the Size menu. To Change , choose Other Variation ... from the Size menu. Try to experiment with different values. Figure 3.20 gives you an example of this type of view.


Figure 3.20. A graphical representation of the coordination around the calcium atom. The maximum variation in distance between neighbouring atoms to the core atom is set to 100 pm. A polyhedron has been inserted around the calcium atom.


Return to CrystalDesigner Home Page
Return User Guide Contents